Alertas

Desbordamiento de pila en VMWare Workstation, Fusion y ESXi (CVE-2021-22045)

El 4 de enero de 2022 se reportó una vulnerabilidad que afectaba a servidores de VMWare Workstation, Fusion y ESXi que permitía al atacante ejecutar código en el hipervisor de la máquina virtual, aprovechando un desbordamiento de pila en el dispositivo de CD-ROM. [1]
07 Jan 2022
1 Minutos de lectura

ANÁLISIS

CVE-2021-22045

La forma de explotar la vulnerabilidad es bastante compleja. Como se ha comentado en la introducción la vía de entrada es mediante un desbordamiento de pila en el dispositivo de CD-ROM de la máquina virtual. No obstante, de esta forma no se tendría un control sobre los datos escritos y su explotación sería difícil, por ello, es necesario que esta vulnerabilidad sea explotada con otras cuestiones como detalles del diseño de la memoria o del SO. De esta forma los atacantes podrían comprometer el sistema operativo, tomar control del hipervisor, gestionar los datos compartidos, instalar archivos o ejecutar código. [2]

Productos afectados:

VMware ESXi                     <=6.5, <=6.7, 7 
VMware Workstation                 16.x 
VMware Fusion                     12.x
VMware Cloud Foundation (ESXi)         3.x, 4.x

No hay prueba de concepto disponible para estas vulnerabilidades.
La puntuación oficial de la vulnerabilidad en CVSSv3 es de 7.7, calificándose así como de Alto riesgo. [3]

 

RECOMENDACIONES

La solución más básica que proporciona VMWare consiste en deshabilitar los dispositivos CD-ROM en todas las máquinas virtuales de la siguiente forma:

  • Iniciar sesión en el servidor VCenter mediante VSphere Web Client
  • Editar la configuración de la máquina virtual
  • Desmarcar las etiquetas "Connected" y "Connected at power On" de los drivers de CD/DVD

    
También puede realizarse con el siguiente comando de Powercli:

Get-VM | Get-CDDrive | Where {$_.extensiondata.connectable.connected -eq $true} | Set-CDDrive -NoMedia -confirm:$false

A pesar de esta solución, es altamente recomendable instalar los parches que solucionan la vulnerabilidad CVE-2021-22045 para cada uno de los productos afectados.

  • VMware ESXi 6.5 : ESXi650-202111101-SG [5]
  • VMware ESXi 6.7 :  ESXi670-202110101-SG [6]
  • VMware ESXi 7 : Pendiente [7]
  • VMware Workstation 16.x  : 16.2.0 [8]
  • VMware Fusion 12.x  :  12.2.0 [8]
  • VMware Cloud Foundation (ESXi) 3.x, 4.x : Pendiente [7]

REFERENCIAS
[1] https://media.cert.europa.eu/static/SecurityAdvisories/2022/CERT-EU-SA2022-001.pdf
[2] https://threatpost.com/unpatched-vmware-bug-hypervisor-takeover/177428/
[3] https://securityonline.info/cve-2021-22045-vmware-workstation-fusion-and-esxi-heap-overflow/
[4] https://securityaffairs.co/wordpress/126352/security/vmware-cve-2021-22045-heap-overflow.html
[5] https://docs.vmware.com/en/VMware-vSphere/6.5/rn/esxi650-202110001.html
[6] https://docs.vmware.com/en/VMware-vSphere/6.7/rn/esxi670-202111001.html
[7] https://kb.vmware.com/s/article/87249
[8] https://kb.vmware.com/s/article/87206
290 visitas