Alertas

Vulnerabilidad Crítica del Kernel de Linux

El martes 2 de Noviembre se publicó una vulnerabilidad que afectaba a algunas versiones del Kernel de Linux.
08 Nov 2021
1 Minutos de lectura

INTRODUCCIÓN

El martes 2 de Noviembre se publicó una vulnerabilidad que afectaba a algunas versiones del Kernel de Linux.

ANÁLISIS

La vulnerabilidad se describe como un desbordamiento de pila en el módulo "net/tipc/crypto.c" [1]. El módulo TIPC del Kernel permite la comunicación de procesos de forma tolerante a fallos. En Septiembre de 2020 se introdujo un nuevo tipo de mensaje, MSG_CRYPTO, que permitía el intercambio de claves criptográficas entre pares. En el código del mismo existía un desbordamiento de buffer que permitía obtener privilegios de kernel de forma local o remota [2].

Las versiones afectadas son:

  •      Linux Kernel >= 5.10-rc1
  •      Linux Kernel < 5.14.16

    
La vulnerabilidad tiene una puntuación CVSS v3 de 9.8, por lo que se considera de severidad crítica. [3]
Podemos encontrar una PoC detallada en un artículo de SentinelLabs [4].

RECOMENDACIONES

La fundación Linux envió un parche el 29 de octubre y confirmó que la vulnerabilidad afecta a las versiones del Kernel 5.10-5.15. Se recomienda actualizar el Kernel a partir de 5.14.16 para solventar la vulnerabilidad.


REFERENCIAS
[1] https://www.cvedetails.com/cve/CVE-2021-43267/
[2] https://cyber-reports.com/2021/11/07/linux-foundation-fixes-dangerous-code-execution-kernel-bug/
[3] https://nvd.nist.gov/vuln/detail/CVE-2021-43267
[4] https://www.sentinelone.com/labs/tipc-remote-linux-kernel-heap-overflow-allows-arbitrary-code-execution/


 

690 visitas