Alertas

Vulnerabilidad crítica para SUDO (Linux)

A día 27 de enero de 2021, una vulnerabilidad crítica para el comando sudo de Linux ha sido publicada. Esta vulnerabilidad permitiría a cualquier usuario local obtener privilegios de root en cualquier sistema Unix sin previa autenticación. [1]
27 Jan 2021
1 Minutos de lectura

ANÁLISIS

La vulnerabilidad de escalada de privilegios ha sido clasificada como CVE-2021-3156 (aka Baron Samedit) [2] , y ha sido descubierta por investigadores de Qualys, quienes la reportaron el 13 de enero asegurando los parcheos correspondientes antes de publicar la vulnerabilidad al resto de la comunidad.

Segun los investigadores de Qualys, la vulnerabilidad reside un desbordamiento del bufer explotable por cualquier usuario local (usuarios normales o de sistema, independientemente de si se encuentran en el fichero de sudoers o no), sin necesidad de conocer la contraseña, permitiendo asi obtener privilegios de root.

Asimismo, los investigadores han publicado 3 exploits [3] como prueba de concepto para demostrar que la vulnerabilidad puede ser explotada por potenciales atacantes. Estas pruebas han sido realizadas en diferentes distribuciones de Linux como Debian 10 (Sudo 1.8.27), Ubuntu 20.04 (Sudo 1.8.31), y Fedora 33 (Sudo 1.9.2). De este modo, consideran que cualquier sistema operativo con soporte para sudo es potencialmente vulnerable a estos exploits.

La comunidad de desarrollo de Sudo ya ha solucionado la vulnerabilidad con la version 1.9.5p2, publicada al mismo tiempo que Qualys reveló su descubrimiento. 


RECOMENDACIONES 

To test if your system is vulnerable, you have to login as a non-root user and run the "sudoedit -s /" command. Vulnerable systems will throw an error starting with "sudoedit:" while patched ones will display an error starting with "usage:".

Se recomienda actualizar la versión de sudo a la 1.9.5p2 o posterior tan pronto como sea posible. 

Para realizar la comprobación de si el sistema es vulnerable se debe ejecutar desde un usuario no-root el comando "sudoedit -s / ". Los sistemas vulnerables lanzarán un error empezando por "sudoedit:", mientras que los sistemas parcheados mostrarán un error que comienza con "usage:".


REFERENCIAS

[1] https://www.bleepingcomputer.com/news/security/new-linux-sudo-flaw-lets-local-users-gain-root-privileges/amp/
[2] https://cve.mitre.org/cgi-bin/cvename.cgi?name=2021-3156
[3] https://www.qualys.com/2021/01/26/cve-2021-3156/baron-samedit-heap-based-overflow-sudo.txt

99 visitas