Alertas

Vulnerabilidad en los controladores lógicos programables(PLC) de Schneider Electric

Recientemente se ha publicado una vulnerabilidad crítica de ejecución remota de código (RCE) en los controladores lógicos programables (PLC) de Schneider Electric.
20 Jul 2021
1 Minutos de lectura

ANÁLISIS

La vulnerabilidad CVE- 2021- 22779  aprovecha los comandos no documentados en el código del dispositivo y permite que los atacantes no autenticados obtengan control con máximos privilegios sobre los PLC utilizados en la fabricación, automatización de edificios, atención médica y entornos empresariales. En caso de explotarse la vulnerabilidad, los atacantes podrían afectar las líneas de producción, los sensores y las cintas transportadoras en la configuración de fábrica, así como ocasionar daños en ascensores y otros dispositivos  automatizados. Dicha vulnerabilidad ha sido calificada con una calificación CVSSv3 de 9.8 [1]. 

La vulnerabilidad de omisión de autenticación por suplantación existe en EcoStructuxure Control Expert ( todas las versiones anteriores a V15.0 SP1, incluidas todas las versiones de Unity Pro), EcoStruxure Control Expert V15.0SP1, EcoStruxure Process Expert (todas las versiones, incluidas aquellas de EcoStruxure Hybrid DCS), SCADAPack Remote Connect para x70 (todas las versiones), CPU Modicon M580 (es decir, las versiones que sean números de pieza BMEP* y BMEH*), CPU MOidcon M340 (versiones de números de pieza BMXP34), que podrían causar acceso no autorizado en modo de lectura y escritura al controlador falsificando la comunicación en Modbus entre el software de ingeniería y el controlador [2]. 
 

RECOMENDACIONES 

Para remediar estas vulnerabilidades, se recomienda aplicar las actualizaciones publicadas por Schneider Electric [3]. 

 

REFERENCIAS

[1] https://threatpost.com/unpatched-critical-rce-industrial-utility-takeovers/167751/
[2] https://nvd.nist.gov/vuln/detail/CVE-2021-22779
[3] https://download.schneider-electric.com/files?p_Doc_Ref=SEVD-2021-194-01

89 visitas