Alertas

Vulnerabilidad crítica VPN Pulse Secure

Recientemente se ha detectado una vulnerabilidad de ejecución remota de código (RCE) posterior a la autenticación en los dispositivos de red privada virtual (VPN) Pulse Connect Secure [1].
12 Aug 2021
1 Minutos de lectura

INTRODUCCIÓN

Recientemente se ha detectado una vulnerabilidad de ejecución remota de código (RCE) posterior a la autenticación en los dispositivos de red privada virtual (VPN) Pulse Connect Secure [1].

ANÁLISIS

La vulnerabilidad CVE- 2021-22937 es una vulnerabilidad de extracción de archivos no controlada en el dispositivo Pulse Connect Secure, que permite a un administrador autenticado escribir archivos ejecutables arbitrarios en el directorio "/ home / runtime / tmp / tt / ". Esta vulnerabilidad de carga de archivos sin restricciones se debe a una falla en la forma en que se extraen los archivos de almacenamiento en la interfaz web del administrador. Una explotación exitosa otorgaría a los atacantes privilegios de root en el dispositivo de destino. Por tanto, un atacante con dicho acceso, podría eludir cualquier restricción impuesta mediante la aplicación web, así como volver a montar el sistema de archivos, lo que le permitiría crear una puerta trasera persistente, extraer y descifrar credenciales, comprometer clientes VPN o pivotar en la red interna [2]. 

Esta vulnerabilidad es una omisión de parche para CVE-2020-8260. 

La vulnerabilidad CVE-2021-22937 recibió una puntuación CVSSv3 de 9.1. 

RECOMENDACIONES 

Para remediar esta vulnerabilidad, se recomienda llevar a cabo la actualización Pulse Connect Secure (PCS) 9.1R12 o posterior [3] [4]. 
 

 

REFERENCIAS

[1] https://es-la.tenable.com/blog/cve-2021-22937-remote-code-execution-patch-bypass-in-pulse-connect-secure?tns_redirect=true
[2] https://www.cronup.com/vulnerabilidad-critica-para-vpn-pulse-secure-cve-2021-22937-patch-bypass/
[3] https://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA44858
[4] https://research.nccgroup.com/2021/08/05/technical-advisory-pulse-connect-secure-rce-via-uncontrolled-archive-extraction-cve-2021-22937-patch-bypass/


 

1134 visitas